1 Reply Latest reply on Dec 7, 2018 11:29 AM by Intel Corporation

    SLOW Network Speed – Intel AC 9560 + 8565U Whiskey lake – HP Spectre 15-Df0068nr

    nosauce1

      HP Spectre 15-Df0068nr (Late 2018 Model)

      - wireless adapter: Intel AC 9560

      - processor: Intel 8565U Whiskey Lake

      - router: Netgear Nighthawk X10 (R9000)

       

      I'm getting less than 25 MB/s read/write on my NAS.  SpeedTest for the Internet is 27 Mbps down

      On my old DELL XPS 9550 with an Intel AC 9260 (Killer 1550) I get 60 MB/s read 95 MB/s write on my NAS. SpeedTest for the Internet is 165 Mbps.

       

      Clearly, something's not right with my new computer. The wireless signal on the bottom right (systray) doesn't have full bars (goes back and forth between full bars and 3/4 bars) despite the router being close by in plain sight. My other computers ALWAYS have full bars despite being farther away with a wall in between. Both my Dell and HP are connected via AC / HT160 / 160MHz (or 80 + 80) and the status reads either 1.7 Gbps or 1.5 Gbps speed, but even if I turn off HT160 and it’s connected at 800Mbps, the speeds for my new HP remain the same (my Dell gets lower Read speed to my NAS ~60MB/s).

       

      My HP is a new model (came on the market late October, 2018). It has a Whiskey Lake processor which has "an integrated Wi-Fi controller supporting 160MHz 802.11ac connections". Is there a big difference between this and just having a regular 9560 card?

       

      I've updated all drivers and the BIOS. I've tried uninstalling the network adapter driver and let Windows installing it on its own. I've tried re-installing the network adapter driver and bluetooth driver many times -- both using the ones from HP's support site (20.70.0.5 Rev.P) and from Intel (20.90.0.7). Interestingly, HP took down the network adapter driver from my model's support site sometime in the last 48 hours:

      https://support.hp.com/us-en/drivers/selfservice/hp-spectre-15-df0000-x360-convertible-pc/23238160/model/24475647?sku=5GQ77UA

      It was the only one on there so currently there are no network adapter drivers on the support site.

       

      Does this mean HP thinks the driver isn't right for my computer?

       

      Another problem that I’m having that may be related is…

      There's "No Internet Connection" after coming out of sleep. It's connected to my router, but there's a yellow exclamation mark over the wifi sign in my systray when it comes out of sleep. The on-mouse-over bubble reads the accurate description, "No Internet Connection". It doesn't happen out of brief sleeps. But this happens whenever the computer sleeps for a couple hours or overnight (deeper S2, S3 sleep?). I can restore Internet by disconnecting and reconnecting to the router (exclamation mark goes away). Running the troubleshooter also restores Internet and reports that the following was fixed: The default gateway is not available. None of my other computers exhibits this problem. It’s always connected to the Internet out of sleep (using same router).

       

      When I try to adjust the advanced power options, a lot of the settings on my other computers don’t exist. I had to modify the registry to get the “Wireless Adapter Settings” back. The “plugged-in” setting was already set to “Maximum Performance”. I changed the “battery” setting to “Maximum Performance” as well, but it did not fix the issue.

       

      1. The other go to thing to try is to uncheck “Allow the computer to turn off this device to save power” in device manager à network adapter à properties à “Power management” tab. There is no power management tab for me. It looks like this person has the tab/option for the same network adapter, Intel AC 9560: https://communities.intel.com/message/572668#572668

       

      Why are these things missing for me? Is it because I did a clean install of windows 10 (64bit Education)?

       

        Any advice for fixing the slow network/internet speed or losing connection out of sleep will be appreciated immensely. Thank you!