1 Reply Latest reply on Dec 7, 2018 3:00 PM by N.Scott.Pearson

    i5 9600k: I'm receiving frequent frame time spiking whilst gaming - Is the CPU faulty or a design flaw? I have replaced every other component in the PC other than the CPU.

    shrib

      Hi,

       

      I'm literally tearing my hair out with this problem. My last option is to RMA the processor, however, I would like to know whether or not this is a fault with my CPU or a flaw inherent to the CPU.

       

      rJULiKv.png

       

      Here's another image representing my problem: Imgur: The magic of the Internet . It's like this in all games - every 30 seconds or so I get a 70ms frame spike, it's particularly bad in Black Ops 4.

       

      Here is a document I have prepared detailing what I have tried (undoubtedly missed some things too):

       

      Build:

      GIGABYTE Z390 AORUS PRO (NEW MOBO: Asrock Z390 Phantom Gaming ITX)

      i5 9600k (Hyper 212 Evo cooler, temperatures are good)

      GTX 970 (SECOND TEST GPU: GTX 770)

      Corsair Vengeance LED 16 GB (2 x 8 GB) DDR4 3000 MHz C15 CMU16GX4M2C3000C15 (OR TEST RAM: Patriot Viper 4 3200Mhz 2 x 8 GB - PV416G320C6K)

      Seasonic SSR-850FX GOLD power supply (SECOND TEST PSU: OCZ ModXStream Pro 700W)

      SAMSUNG SM951 NVMe drive

      SAMSUNG 840 EVO SSD

      Alienware AW2518HF (SECOND TEST MONITOR: ASUS VG248QE)

      All settings are at stock Optimised Defaults (GPU, CPU and RAM all stock) for diagnostic purposes.

       

       

       

       

      Software things I've tried to no avail:

      1. Reinstalling Windows from scratch (I've tried Windows 10 versions: 1511, 1607, 1703, 1709, 1803 and 1809). All Windows installs are kept bloatware free.

      2. Not installing any drivers whatsoever.

      3. Installing every latest driver possible, on the FIRST time having located drivers from my motherboard manufacturer's website. On the SECOND time after no joy, on a separate fresh install using Snappy Driver Installer Origin to locate the latest drivers available. I’ve also tried an earlier LAN and chipset driver.

      4. High performance power plan (this is always the case).

      5. NVIDIA driver settings, 'Prefer Maximum Performance' (this is always the case).

      6. Different NVIDIA drivers, cleanly installed.

      7. Disabling Windows Firewall, disabling Windows Defender, disabling Spectre/Spectre 2/Meltdown mitigations in the OS versions that it is relevant to.

      8. Installed Intel chipset drivers & latest LAN drivers.

      9. Typically I was letting Windows manage the page file, I've also tried disabling the page file completely.

      10. Updating runtime prerequisites such as DirectX.

      11. Tweaking Intel Ethernet configuration to disable power management and disabling various techniques (Interrupt Moderation, Offload, Receive Side Scaling etc).

       

      Hardware things I've tried to no avail:

      1. Different BIOS versions including the F7a beta (tried both ‘Fast’ & ‘Intact’). Updates I have tried have contained earlier or later CPU microcodes depending on BIOS revision.

      3. Disabling ALL power saving techniques in BIOS (C states, EIST, SpeedShift, Turbo Boost) & disabling other features such as CSM, Platform power management, Virtualisation (VT-d), Integrated Graphics etc. Tried disabling RAM specific features such as Rank Interleaving, Realtime Memory Tweaking etc.

      4. Using Integrated graphics – same spikes.

      5. Different Graphics Card with cleanly installed drivers.

      6. Graphics card housed in different PCI-E slot (I've tried it in every slot including the last PCI-E slot).

      7. Disconnecting the fans.

      8. Reseating the CPU.

      9. Installing OS cleanly on SSD 1 (NVMe) after having disconnected SSD 2 (SATA).

      10. Installing OS cleanly on SSD 2 (SATA) after having disconnected SSD 1 (NVMe).

      11. Testing with my old power supply.

      12. Trying mobile internet as opposed to ethernet cable (in case it was an issue with the LAN drivers/ethernet port).

      13. Checking DPC latency using LatencyMon, DPC latency is normal.

      14. A different set of DDR4 RAM from a different manufacturer (both RAM kits are on the QVL list).

      15. Alternative DIMM slots of A1 & B1.

      16. 1 RAM stick installed.

      17. Tried different display monitor: tried DVI-D, tried HDMI, tried DisplayPort.

       

       

       

      Long story short I've replaced every single component to still be plagued with the issue. Are the 9600ks all faulty like this or is it just mine? As you can see in this review @ GamersNexus they also get frame time spiking (also with the 8600k too!): https://www.gamersnexus.net/hwreviews/3407-intel-i5-9600k-cpu-review-vs-2700-2600-8700k e.g. https://www.gamersnexus.net/images/media/2018/cpus/9600k/far-cry-5-frametime-plot.png https://www.gamersnexus.net/hwreviews/3407-intel-i5-9600k-cpu-review-vs-2700-2600-8700k#!/ccomment-comment=10010980

       

      Also Tomshardware seemed to get it too: VRMark, 3DMark and AotS: Escalation - Intel Core i5-9600K Review: A Mid-Range Gamer's CPU e.g. https://img.purch.com/r/711x457/aHR0cDovL21lZGlhLmJlc3RvZm1pY3JvLmNvbS9QL0QvODEzNTA1L29yaWdpbmFsL0FvdFMtRXNjYWxhdGlvbi1G…

      & https://img.purch.com/r/711x457/aHR0cDovL21lZGlhLmJlc3RvZm1pY3JvLmNvbS9QL0gvODEzNTA5L29yaWdpbmFsL0NpdmlsaXphdGlvbi1WSS1GcmFtZVRpbWVvQi0xOTIweDEwODAtRFgxMi1IaWdoLVNldHRpbmdzLnBuZw==

       

      My previous 4 core Haswell didn't suffer from this. Is this a known issue that will be fixed with a microcode update? Is it likely my CPU is faulty? Or what (ponders conspiracy theories)...