1 2 Previous Next 21 Replies Latest reply on Dec 4, 2018 8:48 PM by realsens01

    Frame errors when recording from multiple cameras on a single computer

    realsens01

      I have been trying to use Realsense Viewer to record streams from a pair of  D435 cameras. I continue to experience problems. The problems are somewhat inconsistent. In fact, I thought that the issue had been resolved, but it has recently been happening more frequently. I am looking for ways to systematically isolate and confirm any bottleneck or incompatibility that might exist. Is there a recommended procedure for tracking down such issues? If I need to buy another computer to handle the second camera -- or to abandon the camera entirely -- then so be it, but I'd like to explain and justify the decision. I have so far been unable to understand the issue -- especially since I've seen multiple discussions of applications that use up to 4 cameras on a single computer.

       

      Currently, the primary symptom is that one or both cameras will stop recording mid-session, or will record a significantly reduced number of frames. The "No frames received" message often appears on the Realsense Viewer display.

       

      Some history and context:

      * The computer is a Dell with 8th Generation Intel® Core™ i7-8700K, 8GB RAM, and GeForce GTX 1050Ti

      * Windows 10

      * CPU and RAM utilization do not appear to approach the limit when recording from the two cameras.

      * I've used several versions of Realsense Viewer, including the latest stable release.

      * I have tried moving the cameras around to all of the available front and rear USB ports, in various combinations.

      * These problems occur when the cameras are plugged directly into the PC, using the cables that came with the cameras.

      * I tried several USB PCIe expansion cards.

      * I have tried powered hubs.

      * Sometimes Realsense Viewer detects USB 3.0 devices, and sometimes they are listed as USB 3.1 or USB 3.2.

      * Metadata is enabled.

      * I've compiled Realsense Viewer on the machine, as well as downloading the binary.

      * I've upgraded the graphics drivers.

      * I've upgraded the camera firmware.

       

      There is a LOT of information in the log files, but I am not sure what is relevant. Some potentially useful messages from recent log files:

      * "(win-helpers.cpp:492) CreateFile failed"

      * "(win-helpers.cpp:538) could not find camera in windows device tree"

      * "(win-uvc.cpp:964) Could not retrieve USB descriptor for device"

      * "(environment.cpp:85) Found 1 unreachable streams, 589 extrinsics deleted"

       

      I previously posted some additional information in comments here: https://communities.intel.com/thread/124310. I am not sure if that same exact error still occurs, but the nature of the problem seems similar.

       

      I will appreciate any additional feedback that might be available.

       

      EDIT: I only just now saw this post about providing log information: https://communities.intel.com/community/tech/realsense/blog/2017/02/16/provide-logs-for-faster-more-efficient-service. I will run through this procedure on Monday, and attached the information to this thread.

        1 2 Previous Next