7 Replies Latest reply on Dec 1, 2018 1:56 PM by MartyG

    D435 固件升级(由原先自带的5.9.2.0升级到最新版5.10.6)出错

    abijoy

      D435固件升级时,相机连接老是自动断开。

       

      22GR8LZ_%V40SR6)@B2NMSN.png7H_K59}05H`M(NV8YS$TTUF.png

        • 1. Re: D435 固件升级(由原先自带的5.9.2.0升级到最新版5.10.6)出错
          MartyG

          Abijoy had a DFU error (No DFU device was connected.  Failed to burn firmware) when upgrading their D435 from the original 5.9.2 firmware to 5.10.3.  They said, "When the firmware is upgraded, the camera connection is always disconnected automatically".

           

          Abijoy, please first check that your USB port is of the USB 3.1 type.  Although the camera works with USB 3.0, the firmware updating tool wants USB 3.1.

           

          If you do have a USB 3.1 port and the updater tool is still not working, this suggests that you may have a corrupted calibration table inside your camera.  A corrupted table will prevent the DFU tool from updating the firmware.  This can be fixed by doing a 'gold reset' of your camera with a tool called CustomRW.

           

          STEP ONE

           

          Download the custom calibration tool (CalibrationAPI-2.6.4.0-Setup.exe), which contains the CustomRW program.

           

          Download Intel® RealSense™ D400 Series Calibration Tools and API

           

          STEP TWO

           

          Run this instruction to perform a 'gold reset' of your camera to fix a corrupted calibration table.

           

          Intel.Realsense.CustomRW.exe -g

           

          You should now hopefully be able to update your firmware with the DFU updater tool.

           

          **********

           

          CHINESE TRANSLATION

           

          將D435從原來的5.9.2固件升級到5.10.3時,Abijoy出現DFU錯誤(沒有連接DFU設備。無法刻錄固件)。他們說,“固件升級後,相機連接總是自動斷開”。

           

          Abijoy,請先檢查您的USB端口是USB 3.1類型。雖然相機可以使用USB 3.0,但固件更新工具需要USB 3.1。

           

          如果您有USB 3.1端口並且更新程序工具仍無法正常工作,則表明您的相機內部可能存在損壞的校準表。損壞的表將阻止DFU工具更新固件。這可以通過使用名為CustomRW的工具對相機進行“黃金重置”來解決。

           

          第一步

           

          下載自定義校準工具(CalibrationAPI-2.6.4.0-Setup.exe),其中包含CustomRW程序。

           

          下載英特爾®實感™D400系列校準工具和API

           

          第二步

           

          運行此指令以執行相機的“黃金重置”以修復損壞的校準表。

           

          Intel.Realsense.CustomRW.exe -g

           

          您現在應該能夠使用DFU更新程序工具更新固件。

          • 2. Re: D435 固件升级(由原先自带的5.9.2.0升级到最新版5.10.6)出错
            yjiao

            Hi Marty,

            I also encountered the same issue as Abijoy. I follow your instructions to "gold reset" my camera, but the CustomRW reported that "Realsense camera is not plugged in."

             

            PS C:\CalibrationToolAPI\2.6.4.0\bin> .\Intel.Realsense.CustomRW.exe -g

            CustomRW for Intel RealSense D400, Version: 2.6.4.0

             

             

            Realsense camera is not plugged in.

             

            My PC is the 6th Gen X1 Carbon, so I believe I only have USB 3.0. And the operating system is Windows 10 1803. I also noticed westa's thread:

            No DFU device was connected : Realsense 435 Firmware Upgrade . westa claimed that it might be related to a Windows 10 update, and his issue is not yet solved since he just changed another computer.

            • 3. Re: D435 固件升级(由原先自带的5.9.2.0升级到最新版5.10.6)出错
              MartyG

              Although the camera works with USB 3.0, the DFU fimrware updater tool's specification asks for USB 3.1.

              • 4. Re: D435 固件升级(由原先自带的5.9.2.0升级到最新版5.10.6)出错
                yjiao

                Hi MartyG, do you mean I must have a USB 3.1 port for updating the DFU firmware?

                • 5. Re: D435 固件升级(由原先自带的5.9.2.0升级到最新版5.10.6)出错
                  MartyG

                  The specification does ask for USB 3.1 for the firmware updater, yes.  I have not heard of any cases of it working with USB 3.0.

                   

                  Regarding whether the X1 Carbon 6th Generation has USB 3.0 or 3.1, reviews of the machine are contradictory.  Some say 3.0, some say 3.1.  If the machine was released in 2018, I would be surprised if it was still using 3.0. 

                   

                  If you run the RealSense Viewer program and look beside the camera name at the top of the options side-panel, it should indicate which USB type is being detected on your particular PC's USB port.

                   

                  • 6. Re: D435 固件升级(由原先自带的5.9.2.0升级到最新版5.10.6)出错
                    yjiao

                    Hi MartyG, instead of showing USB 3.x, the RealSense Viewer shows that I am using a USB 2 port(whatever any port I am using). It is impossible that my machine still has a USB 2.x port. I tried the "hardware reset" button as in this thread , but it did not work.

                     

                    As I mentioned in the other thread, I am using my own USB-C cable which is originally for my mobile phone. I don't know if the cable is the issue, but for now I do not have the official cable to test out.

                    • 7. Re: D435 固件升级(由原先自带的5.9.2.0升级到最新版5.10.6)出错
                      MartyG

                      It is not unusual for it to show as USB 2 when using your own choice of cable, even when it is plugged into a USB 3 port.   The quality of third party USB-C cables can vary.  You may find you can update the firmware successfully with the official short cable.

                       

                      The link below has recommendations for USB cables that should work with the 400 Series cameras.

                       

                      Re: New cable not working for realsense d415