1 2 Previous Next 21 Replies Latest reply on Nov 21, 2018 7:57 AM by ReverendReasons

    How to enable Radeon Vega M

    buddhasai

      Category

      Questions

      Answers (N/A if not applicable)

      Description

      Provide a detailed description of the issue

      I just got my new HP Spectre 360 with the Radon Vega M GPU. I was playing Minecraft as my first game on the laptop. I noticed it only played on the Intel GPU and not the Vega. I confirmed this by looking at the task manager Performance viewer. How do I switch the game to use the Vega GPU?

      Please place an X to the right of the option showing how often you see this issue using specific steps. (Ex: 'Every few times a game is started it flickers.' <- This would be "Often")

      Always (100%): X

      Often (51-99%):

      Sporadic (20-50%):

      Very Sporadic (<20%):

      Hardware (HW)

      Brand and Model of the system.

      2018 HP Spectre 15 360

      Hybrid or switchable graphics system?
      ie Does it have AMD or NV graphics too?

      Switchable I think. AMD and Intel

      Make and model of any Displays that are used to see the issue (see note2 below).
      LFP
      = Local Flat Panel (Laptop panel)
      EFP = External Flat Panel (Monitor you plug in)

      LFP

      How much memory [RAM] in the system (see note2 below).

      12gb

      Provide any other hardware needed to replicate the issue.
      ie: Cables&brand, cable type [vga, hdmi, DP, etc], dock, dongles/adapters, etc

       

      Hardware Stepping (see note1 below).

       

      Software (SW)

      Operating System version (see note2 below).

      Windows 10 Home

      VBIOS (video BIOS) version. This can be found in “information page” of CUI (right click on Desktop and select “Graphics Properties”.

       

      Graphics Driver version; for both integrated Intel and 3rd party vendors (see note2 below).

      Intel: 23.20.16.4973

      Radeon: 23.20.792.1280

      SW or Apps version used to replicate the issue.

      Minecraft 1.12.2

      Configurations

      Single display, clone, or extended (see note2 below).

      Single laptop display

      Display resolution & refresh rate setting of each display (see note2 below).

      4k

      AC or DC mode, i.e. is power cable plugged in or not?

       

      How to repro

      Please provide steps to replicate the issue.  These steps are very crucial to finding the root cause and fix.
      A screenshot to illustrate the issue is a huge plus. A video of the failure is even better! Attach to the post or provide the YouTube link.

      1. Run Minecraft from Windows Launcher.

      2. I tried using the Intel Radeon Setting and added Minecraft as a gaming profile.

      3. I Launched minecraft from the gaming profile. Still no joy.

      4. In addition, I am unable to see minecraft in either the Recent Applications or Current Applications in the Switchable Graphics tab.

        • 1. Re: How to enable Radeon Vega M
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello buddhasai

          Thank you for joining the Intel Community Support.

          Your computer should automatically use Radeon Graphics to open games such as Minecraft, but I will do further research about this issue.

          I am still missing some information about your system. Please run the Intel® System Support Utility.

          Follow these steps:

          1.Download the Intel® System Support Utility and save the application to your system.
          https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91600
          2.Open the application and click Scan to see system and device information. The Intel® System Support Utility defaults to the Summary View on the output screen following the scan. Click the menu where it says summary to change to Detailed View.
          3.To save your scan, click Next and click Save. You can save the file to any accessible location on your computer.
          4. Attach the report to this thread.

          Wanner G. 

          • 2. Re: How to enable Radeon Vega M
            buddhasai

            Hey Wanner!

             

            Thanks for the swift response. I've attached scan report here.

            • 3. Re: How to enable Radeon Vega M
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello buddhasai

              Thank you for your response. 

              I will replicate this issue. I will provide the results once available. 

              Wanner G. 

              • 4. Re: How to enable Radeon Vega M
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hello buddhasai

                I am sorry for the delay. 

                We are trying to reproduce your issue to provide further information about it.

                I will get back to you soon. 

                Wanner G.

                • 5. Re: How to enable Radeon Vega M
                  devilslayersbane

                  Hi,

                   

                  I have had the exact same issue with 2 other games (I haven't tried any others) on my Dell XPS 9575. Dark Souls Remastered (DSR) and TES III: Morrowind (Morrowind) both do not detect the Radeon Vega M GPU and instead default to the Intel HD 630. As above with OP, adding profiles doesn't work but even trying to manually add the applications via the "switchable graphics" menu in Radeon Settings doesn't work out. In trying to manually add it will freeze the Radeon Settings menu.

                   

                  Here's what I have tried:

                  1: uninstalled and reinstalled the Vega GPU driver.

                   

                  2: uninstalled and reinstalled the applications in question.

                   

                  3: tried using Morrowind's launcher options use the Vega GPU (did not show up in there, there's no such option in DSR).

                   

                  4: tried disabling the intel GPU (they just switched to microsoft's basic display adapter)

                   

                  5: tried disabling the ms basic display adapter (they still only wanted that adapter, even though it was disabled).

                   

                  6: tried steps 5 and 6, but the the relevant display drivers uninstalled as opposed to disabled.

                   

                   

                  I tried contacting dell's support on this, but they ended up taking me through the above steps again. So I'm a bit at a loss here. Programs like Blender detect it just fine, but DSR and Morrowind seem to have difficulty actually just detecting the Vega GPU. I went ahead a attached my XPS system information.

                  • 6. Re: How to enable Radeon Vega M
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Hello devilslayersbane

                    I understand that you are having issues with Radeon™ RX Vega M GL Graphics. I will assist you with this.

                    First, try installing this driver for Radeon™ RX Vega M GL Graphics:
                    https://downloadcenter.intel.com/download/27881/Graphics-Radeon-RX-Vega-M-Graphics?product=136865

                    Then, please follow these steps to force your computer to open games with Radeon RX Vega M.

                    1. Right click on desktop and select Radeon RX Vega M Settings
                    2. Click on Gaming 
                    3. Click Add option on the right hand corner 
                    4. Click on browse, then look for the desire application 
                    5. Once the application has been added, click on the 3 dots next to it and click on Launch. 

                    If you are unable to resolve the issue by performing these steps, please fill out this information and attach all the reports, too.
                    https://communities.intel.com/thread/77761

                    Wanner G. 

                    • 7. Re: How to enable Radeon Vega M
                      devilslayersbane

                      You're right. I hadn't reinstalled the drivers. Still, I went ahead and did that and the attached picture is what I got after following your instructions.

                       

                      I definitely appreciate you all looking into this.

                      • 8. Re: How to enable Radeon Vega M
                        devilslayersbane

                        Category

                        Questions

                        Answers (N/A if not applicable)

                        Description

                        Provide a detailed description of the issue

                        Games do not detect Vega GPU on XPS 15 w/ Kaby Lake G, manual entry of games via Radeon Settings freezes program (note that computer still functions).

                        Please place an X to the right of the option showing how often you see this issue using specific steps. (Ex: 'Every few times a game is started it flickers.' <- This would be "Often")

                        Always (100%): X

                        Often (51-99%):

                        Sporadic (20-50%):

                        Very Sporadic (<20%):

                        Hardware (HW)

                        Brand and Model of the system.

                        Dell XPS 15 9575

                        Hybrid or switchable graphics system?
                        ie Does it have AMD or NV graphics too?

                        Switchable w/ AMD Vega

                        Make and model of any Displays that are used to see the issue (see note2 below).
                        LFP
                        = Local Flat Panel (Laptop panel)
                        EFP = External Flat Panel (Monitor you plug in)

                        LFP

                        How much memory [RAM] in the system (see note2 below).

                        16 GB DDR4

                        Provide any other hardware needed to replicate the issue.
                        ie: Cables&brand, cable type [vga, hdmi, DP, etc], dock, dongles/adapters, etc

                        N/A

                        Hardware Stepping (see note1 below).

                        See attachment

                        Software (SW)

                        Operating System version (see note2 below).

                        Windows 10 Pro version 1803 (also replicable on 1709) (see attachment, too)

                        VBIOS (video BIOS) version. This can be found in “information page” of CUI (right click on Desktop and select “Graphics Properties”.

                        015.051.000.000

                        Graphics Driver version; for both integrated Intel and 3rd party vendors (see note2 below).

                        18.10.01.08 (SSU listed Open CL version)

                        SW or Apps version used to replicate the issue.

                        Dark Souls Remastered, TES III: Morrowind,

                        Configurations

                        Single display, clone, or extended (see note2 below).

                        Single Display

                        Display resolution & refresh rate setting of each display (see note2 below).

                        3840x2160

                        AC or DC mode, i.e. is power cable plugged in or not?

                        AC (both would probably yield similar results).

                        How to repro

                        Please provide steps to replicate the issue.  These steps are very crucial to finding the root cause and fix.
                        A screenshot to illustrate the issue is a huge plus. A video of the failure is even better! Attach to the post or provide the YouTube link.

                        1. Morrowind will provide more direct results, try it first.
                        2. Start the Morrowind Launcher
                        3. Click "Options"
                        4. Click drop down menu next to "adapter"
                        5. Start Dark Souls Remastered
                        6. Alt-tab out at the main menu
                        7. Open task manager and click on performance tab
                        8. Note the GPU 0 (intel 630) usage vs GPU 1 (Vega) usage
                        9. Try steps 1-8 but with the radeon settings menu.
                        10. In radeon settings hit "System"
                        11. Click "Switchable Graphics"
                        12. Click "running applications"
                        13. Select "Installed profiled applications"
                        14. Attempt to add either Dark Souls Remastered or Morrowind and either will freeze the radeon settings menu.

                        ...

                        I also updated my info using SSU. The above steps are all the ones that I took to replicate this issue on my own. However, I did also try entirely disabling the HD 630 GPU, but the above steps still worked and the applications in question were still unable to run on the vega gpu. Blender, however, runs fine on the Vega GPU. I was pleasantly surprised with that one.

                        • 9. Re: How to enable Radeon Vega M
                          Intel Corporation
                          This message was posted on behalf of Intel Corporation

                          Hello devilslayersbane

                          Thank you for your response and the information provided. 

                          We are working on reproducing this issue to provide further steps about the behavior of Radeon™ RX Vega M Graphics when opening games. 

                          Wanner G. 

                          • 10. Re: How to enable Radeon Vega M
                            rikshi

                            I would like to add on that I am having the same issues with my Dell XPS 15 2 in 1. In addition to that, I am unable to switch graphics for applications outside gaming, such as CAD software.

                            • 11. Re: How to enable Radeon Vega M
                              Intel Corporation
                              This message was posted on behalf of Intel Corporation

                              Hello rikshi

                              Thank you for joining the Intel Community Support.

                              I would like to have more information about your system and the games you are playing as well. 

                              Please fill out this information and attach all the reports.

                              https://communities.intel.com/thread/77761

                              Wanner G.

                              • 12. Re: How to enable Radeon Vega M
                                Debz30

                                I am also having this same issue with Dell XPS 9575. It won't use the RX Vega M graphics card with "Rise of the Tomb Raider". That's the only game I've tested so far. I've done updates, installed drivers, un-installed/re-installed the game. Even tried Intel's suggestion to right click on desktop, and go to Radeon RX Vega M settings, and click on "Gaming", click "add", and I can click on "Rise of the Tomb Raider" app, but it won't even add it. It does nothing.

                                • 13. Re: How to enable Radeon Vega M
                                  Debz30

                                  system info attached

                                  • 14. Re: How to enable Radeon Vega M
                                    devilslayersbane

                                    Ok, so I figured out my issue. It was due to a bit of an assumption on my part. I decided to try and get the games working one more time when I realized that the dialog box to search for programs was looking at my desktop. The shortcuts that steam puts on one's desktop are internet shortcuts (kind of) and just confused the radeon settings menu when I tried to use those. I was able to navigate to my steam app library and use the actual executable to activate the radeon gpu for the games.

                                     

                                    I think to avoid this confusion in the future, it would be wise to set the default location of browser for the switchable graphics to "C:\programfiles(x86)\" as opposed to the desktop. Or you can work with Valve to resolve this issue of the shortcuts not directing to the application properly. Hopefully this solves it for everyone else here, too.

                                     

                                    Just for clarity, here's my resolution steps that I tried and found successful:

                                    1: navigate to the radeon settings menu

                                    2: click system then switchable graphics

                                    3: click running applications and change it to installed profiled applications

                                    4: click browse, navigate to the proper .exe in your respective steam folder

                                    5: profit.

                                     

                                    Thank you for investigating this Intel!

                                    2 of 2 people found this helpful
                                    1 2 Previous Next